Re: Error running Sawfish-ui on Ubuntu

Hi Grant

On Fri, 7 May 2010 19:46:23 +0100 Grant Sewell <dcglug thymox co uk> wrote:

> Hi all,
> I used to love Sawfish but lost track of it over the years.  I've tried
> installing and running Sawfish on my Ubuntu 10.04 system (x86, upgraded
> 8.04 -> 8.10 -> 9.04 -> 9.10 -> 10.04 - this is *not* a fresh 10.04
> system) but I'm hitting a bit of a snag with rep.
> I've installed the following from the Ubuntu repo's:
> sawfish			1:
> sawfish-data		1:
> sawfish-dbg		1:
> sawfish-lisp-source	1:
> sawfish-merlin-ugliness	1.3.1-1
> sawfish-pager		0.6a-3
> sawfish-themes		0.12
> librep9			0.90.2-1
> rep-gtk			1:0.90.0-2
> Rather than jumping straight into Sawfish as a full-on window manager
> for my main system, I've been trying to play with it in a Xephyr X
> session.
> Running Xephyr is OK.
> Running xterm in the Xephyr session is OK.
> Starting sawfish from said xterm session is OK and indeed the xterm
> gets some nice window decorations.
> Running sawfish-ui from the xterm within the Xephyr session, however,
> presents me with the following error:
>   exec: 8: rep: not found
> Fair enough, one "apt-get install rep" later and the above error has
> gone!  Only to be replaced by a much less helpful (to me) error:
>   eval_req: Connection reset by peer
>   **** Remote sawfish error: unknown error
> What's going on?  How can I fix this?

I had this problem on Ubuntu 9.10.  Probably your problem is the same as

I've worked around that problem by applying a patch which fixes the
problem and rebuilding the sawfish package.

I've put some instructions at
(in portuguese, but the sequence of commands should be understandable).

The patch is from

Best wishes.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]