Re: sawfish-config segfault

On Thu, 7 Jan 2010 13:33:03 +0100, Janek Kozicki wrote:
> Christopher Roy Bratusek said:     (by the date of Thu, 7 Jan 2010 13:24:00 +0100)
>> Valgrind gives nothing for sawfish-config, coredump only this:
>> #0  0x00007fe728ee4478 in ?? ()
> that's seriously weird.

Hey guys, glad the crash is fixed, but the sawfish-config is a shell
script, so you've got to embed debugger call into it. Have a look at

# I tried: `REP_LOAD_PATH=... exec ...' but solaris /bin/sh won't play along


exec rep "$0" "$@"


;;; lisp code follows...

Currently sawfish-config / -script are byte-compiled and put under
/usr/bin. In fact, I've been thinking that the bare sources, not
the byte-compiled ones, are better, because users can read them.
If they want a hack, then they can get it by editing. (I needed it
when I tried to solve the mystery of non-English letters

Teika (Teika kazura)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]