Re: on viewport; doc review request & questions

On Sat, 21 Nov 2009 12:05:29 -0600, Jeremy Hankins wrote:
> Teika Kazura <teika lavabit com> writes:
>> Hi, I've done some work on viewport, especially in doc. 

> [... ]and window-relative-position,
> since that's exactly what window-relative-position is supposed to do.

Sorry, I was wrong on window-relative-position. (The opposite of
your case. ;) Oh, I made wrong changes on doc, too. I'll fix it.

>> I've renamed viewport-offset to viewport-offset-pixel.
> Why?  It was named viewport-offset to match the viewport-x-offset and
> viewport-y-offset variables.  If you think it should be renamed, how
> about viewport-offset-coords, and viewport-[xy]-offset-coords?  "Pixel"
> in my mind suggests bits of light on the display, which isn't really
> right here. 

What's needed is the disambiguation between (2048 . 768) and (2 . 1).
"Coordinates" and "xy" can mean both. Those who read viewport.jl
are first forced to decipher this distinction, so my change is in
the right direction. I'll put a comment on viewport-x-offset that 
it's pixel.

Yes, I feel a bit peculiar about "pixel". Yet coordinates in raw X are
by pixel.

>> (to: sawfish-list cc: jeremy)
> In general I prefer to have it go only to the list.


Teika (Teika kazura)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]