[NEWS] Sawfish is now intltoolized! / librep.spec.in and autogen.sh issues solved

Hi all,

some updates

***** sawfish *****

I contacted the translationteam for doing updates, but first I had to
intltoolize sawfish. It was "just" two tasks.

- removing deprecated stuff from po/
- marking all translatable strings with (_ ) ... bloody fingers ...

***** personal bugs *****

... But I'm having a pretty strange Issue: Not all strings are getting
translated properly:

A) somehow randomly
B) they are truncated before some special german chars (ä ü ö ß)

Would be nice, if someone could test this case on his/her machine (make
sure de_DE.UTF-8 locale exists on your machine and that you have sawfish
1.5.0 revision 4381 (or newer) installed), by running:

killall -qw sawfish && sleep 5 && LANG=de_DE.UTF-8 sawfish

then run sawfish-ui and post a screenshot of sawfish-ui -> Sawfish ->
Aussehen -> Minihilfen

Here's how it looks like on my system:

That's not all:


The pager defcustoms absolutely show no text.

***** public bugs *****

There's a bug in the microgui theme:

There's a problem with move-cursor:

***** librep *****

3 issues are solved now:

autogen.sh does currently not run autoheader (to workaround the "missing
template .*" issue)

fixed two issues in the specfile: rep.m4 (which does not exists anymore)
is not beeing packaged and we ensure emacs_lispdir is defined

***** this mail will destroy itself in 5 minutes *****

Happy Hacking,

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]