Re: The sound of silence :-(


>>>>> On Fri, 16 Jan 2004 21:25:35 -0700, Eric Mangold <teratorn world-net net> said:

  >> I noticed that with sawfish on GNOME2, resizing the Emacs window
  >> will cause it to display a geometry-spec that's off by 4 for the
  >> width of the window.  For example, if I want the Emacs window to
  >> be 80 columns wide, I have to size it to be 84 columns wide (as
  >> per geometry info displayed by sawfish).  This used to work just
  >> fine under GNOME1.  It appears that only Emacs is affected.
  >> Resizing of, say, an xterm window works just fine.  Anybody else
  >> seen anything similar?

  Eric> I can reproduce this with emacs but not with xemacs nor
  Eric> anything else I've tried. Using gnome2 doesn't make a
  Eric> difference. icewm shows the correct horizontal
  Eric> dimension. Hmmm.. I don't have any idea why :)

Yes, I don't see the problem with other programs either.  I don't know
about xemacs, but xterm is also OK.  But I don't think the problem is
with emacs per se.  I know it used to work fine with emacs21 from
Debian/stable and I just tried downgrading to it and it also shows the
"bad text width" problem.

I dug some more and it's getting rather more bizarre: the problem
seems to be triggered by using a geometry of 80x46-0-0.  The last -0
is the important one here.  If I change the geometry to 80x46-0-1, the
text width comes out correct!  To be clear,

 this command gets the bad  width display: emacs -geometry 80x46-0-0
 this command gets the good width display: emacs -geometry 80x46-0-1

I thought the problem might be due to gnome-panel.  However, if I do:

	$ Xnest -ac :1 &
	$ DISPLAY=:1 sawfish &
	$ DISPLAY=:1 emacs -geometry 80x25-0-0

The width display is also bad.
On the other hand, if I do "xterm -geometry 80x25-0-0" there is no problem.

Anybody have an idea where this might be coming from?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]