Re: [Rhythmbox-devel] Rhythmbox only partially importing library -> Solved!


following up on my own post... I think I solved it.

- Turns out that I had two random subdirectories, one of which was called " (Disc " ; the other directory also started with a space.

Removed those, and rhythmbox now finds 24852, where squeezebox reports 24866..
(I need to figure out how to find those 14 missing files.)

Even importing seems to be working alright again!

On Sat, Dec 24, 2011 at 12:26, Tim T. <tim timmerman gmail com> wrote:

Ubuntu, 11.04 platform, rhythmbox 0.13.3

  I recently switched from a VIA-EPIA based server, which exported my music library over NFS to a Synology NAS, also exporting the library over NFS.

After I changed the library location in Rhythmbox, everything went smoothly; rhythmbox picked up about 3/4ths of my moved library.. Not all, but I was still in an experimental phase, and didn't have permissions set up correctly.

I tried adding some new music to the library, and found that only 10 % was imported into rhythmbox. At the same time, my squeezebox server was picking up the entire library.

Removed all rhythmbox files and deinstalled rhythmbox, reinstalled and reimported the library : Only picked up 5000 or so songs out of a collection of 26000 or so.

My questions:
  - How can I debug what's going on here ?
  - What is the correct way of reimporting a library (I really don't want to move that much data around again..)
  - Is there a backport of the 2.9 series for Ubuntu 11.04 ?

One possible further data point: I have a lot of Greek, Chinese and Indian music. Not all artists' names are in standard US character set.

Any suggestions ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]