Re: [Rhythmbox-devel] crash when loading music directories

James Livingston wrote:
On Wed, 2006-02-08 at 19:37 -0700, Nathan wrote:
      * When I tried to start it, I got a message saying it couldn't

This means that you have upgraded to dbus 0.6, and something that
Rhythmbox uses hasn't been recompiled. I've seen several of these
reports before, and it usually turnout out to gnome-vfs.

If you try to run "gnomevfs-ls" do you get the same error? If so, then
it is gnome-vfs thet needs rebuilding.

gnomevfs-ls looks OK.  I get a nice little directory listing, so I think that part is working.
      * I have so I created a symlink for, ended up doing the same thing for

The reason for chaning the library version number is that they are API
and ABI incompatible - you *need* to rebuild whatever it is that needs

It is probably crashing when RB tried to use gnome-vfs for something
that needs to talk to it's daemon (which goes over dbus).


James "Doc" Livingston
I took the symlink out, and the exact error is:

rhythmbox: error while loading shared libraries: cannot open shared object file: No such file or directory

Is there any good way of tracking down what needs to be re-compiled?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]