Re: [Rhythmbox-devel] Writing to iPod

To test to see if most of this stuff is working, if you plug in a usb
key and nautilus pops up and/or something new shows up in the drive
mount applet, then I think everything right up until libipoddevice is
probably working ok. Just to narrow it down

On 12/5/06, Peter Colijn <caffeine colijn ca> wrote:
Hi Jason,

Whereas gtkpod uses a very simple model where you have to manually
figure stuff out and mount your iPod somewhere, there are actually a
lot of moving pieces required to get the iPod working seamlessly with
Rhythmbox. HAL, dbus, gnome-volume-manager, pmount and libipoddevice
all need to work together. If any piece breaks, the whole thing
doesn't work.

That said, try some of the stuff suggested here:

[yes, it's for Banshee, but both Banshee and Rhythmbox use largely the
same infrastructure to talk to iPods]

One thing that bit me the first time I tried was that I was not in the
'plugdev' group. You might look into that.

Have fun,

On 12/4/06, Jason Bodnar <jason shakabuku org> wrote:
> I have a new iPod shuffle (the clip kind, I think it's considered a sixth
> generation iPod). I can successfully transfer mp3s to it using gtkpod (though
> it's not very intuitive), but for
> the life of me I can't figure out how to do it with Rhythmbox.
> I'm using rhythmbox 9.6 (Fedora Development rpm: rhythmbox-0.9.6-3.fc7). rb
> 9.6 is supposed to have ipod writing on by default so I've looked at the rpm
> spec file and it configures the build as so:
> %configure \
>         --with-ipod \
>         --with-dbus \
>         --with-mdns=avahi \
>         --disable-scrollkeeper \
>         --enable-tag-writing
> So that should all that's needed to copy tracks to an iPod, correct? So, what
> am I missing? I've tried dragging artists, albums and highlighted tracks to
> the iPod icon in the left panel, but the dragged icon just retreats back to
> its origin. I've tried Edit-> Copy but Paste is deactivated when I then select
> the iPod. Am I doing something wrong? Is it possible that iPod writing is not
> turned on for this rpm version of rb? Is there an easy way for me to check that?
> Thank you,
> Jason
> --
> Jason Bodnar
> jason shakabuku org
> UnWired Buyer. The best way to win on eBay. Period.
> _______________________________________________
> rhythmbox-devel mailing list
> rhythmbox-devel gnome org
rhythmbox-devel mailing list
rhythmbox-devel gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]