Re: Request for API/ABI breaks in glib/gio
- From: Sven Herzberg <herzi gnome-de org>
- To: Alexander Larsson <alexl redhat com>
- Cc: Gnome Release Team <release-team gnome org>, gtk-devel-list <gtk-devel-list gnome org>
- Subject: Re: Request for API/ABI breaks in glib/gio
- Date: Fri, 22 Feb 2008 18:00:23 +0100
Am Freitag, den 22.02.2008, 16:34 +0100 schrieb Alexander Larsson:
> The first one concerns g_uri_get_scheme. The webkit developers has plans
> to add a GUri object in glib, and g_uri_get_scheme (which takes a uri
> string and returns the scheme part) would conflict with the g_uri_
> namespace. Current proposal is to rename it to g_uri_parse_scheme.
Wouldn't g_parse_uri_scheme() keep the g_uri_ namespace completely free?
We've also discussed natural language order quite excessively but if ot
comes for free when trying to preserve a namespace?
> The other one is g_file_contains_file(). This was deprecated in favour
> of a new identical functions called g_file_has_prefix() which betted
> describes what it does. We still carry a macro that defines
> g_file_contains_file to g_file_has_prefix, and a symbol for binary
> backwards compat. However, this has a few more users. One in evince, one
> in the panel, on in libgnomeui. (The uses in gvfs and nautilus has been
IIRC, gio hasn't had any "guaranteed-stable" release, right? So you
could still just drop it I guess.
> Its kind of bad to have to keep this compat function forever, not being
> able to e.g. reuse that name for a better purpose. However, making this
> change requires changing a few other packages, which is slightly more
> problematic than the above. I'm not sure what the best approach is. What
> is the opinion of the release team?
I'm not on the release team, but I'd say +1 (to both) as having a
mostly-clean API from the beginning should be good for everyone.
] [Thread Prev