Re: GNOME 2.18 Avahi 0.6.13 dependancy incorrect

On 1/25/07, Trent Lloyd <lathiat bur st> wrote:

It appears GNOME 2.18 has Avahi 0.6.13 as the recommended Avahi version.

Unfortunately Avahi 0.6.13 does not compile with dbus >= 1.0
Relevant Bug:
This was fixed in 0.6.16

I would recommend bringing the recommendation to the latest version
(0.6.16) + this patch:

We will be release 0.6.17 shortly, probably this weekend, which will
include the above patch, but at the very least recommending 0.6.16 would
be good.

Oops, I rebuilt gnome with jhbuild to try to shake out any dependency
issues with the new dbus, but not in a clean prefix and of course
jhbuild doesn't rebuild tarballs whose versions haven't changed.
Thanks for catching this.  I updated the dependency to 0.6.16.

You gave no explanation of why that patch would be needed or important
(other than that it appears to be included upstream) and the link you
provided has no information about its impact either.  Given that we
tend to prefer using unpatched tarballs where possible and don't have
any extra info to tell us why we shouldn't, I'd rather wait until
0.6.17 is out at least with a bit more testing.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]