trying to get things going

I've been playing with the 'full local build' scenario, by trying to
follow Colins 'amazon build server' instructions on my local system.
After a number of false starts, I managed to get a complete bitbake
run, and then a complete 'ostbuild build' run as well.

Some observations:

Quite a few of the gnu modules in yocto fail to build on f18. This is
because recent glibc decided to hide gets in the header, which upsets
the gnulib stdio.h wrapper. They all need the same patch. I guess this
will sort itself out over time.

After completing the build, I wanted to try things in a vm, but I ran
into some issues with ostbuild deploy-qemu.

First, qemu-img was missing; I didn't get a very clear error message
for this. Would be good to improve that, since ostbuild runs quite a
few external commands that may be missing.

After installing qemu-img, the next problem was that ostbuild pkexec's
itself to run privhelper-deploy-qemu. Nothing wrong with that in
principle, but the pkexec'ed command can't find the ostree and
ostadmin binaries which are located in my jhbuild tree. I've worked
around this by patching full paths into the privhelper code - a better
solution is clearly required.

Finally, I end up with
$ ostbuild deploy-qemu gnomeos-3.6-i686-runtime
ostbuild: running: pkexec ostbuild privhelper-deploy-qemu
/home/mclasen/build/ostbuild/shadow-repo gnomeos-3.6-i686-runtime
ostbuild: running: /home/mclasen/build/jhbuild/bin/ostree
--repo=/ostree/ostree-qemu-mnt/ostree/repo pull-local
/home/mclasen/build/ostbuild/shadow-repo gnomeos-3.6-i686-runtime
Rev 'gnomeos-3.6-i686-runtime' not found
Not sure how to solve this.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]