Re: [orca-list] lost speech upgrading from jessie to stretch

No, the ps command didn't show speech-dispatcher. Yes, I get an error when I use the spd-say command.

I did

aptitude reinstall speech-dispatcher

and then rebooted. Orca spoke for logging in but then was silent. I reinstalled gnome-orca and rebgooted yet again, and had the same problem. The ps command shows orca running but not speech-dispatcher.

I also still have the problem that I get speech through the speakers but not the headphones. This matters because my wife and I are often up here using the two computers at the same time.



On 8/15/2017 6:16 AM, José Vilmar Estácio de Souza wrote:
The ps command didn't show speech-dispatcher?

When you run spd-say do you get some error in the console?

Do you have access to the logs of speech-dispatcher?

On 08/14/2017 06:15 PM, Al Sten-Clanton wrote:
Thanks!  Looks like speech-dispatcher's not workking.  The ps command
indicates that Orca is running.

I know this, by the way, because I'm now getting speakup through my
speakers but not my headphones.  (Just somehow thought to test this.)
Any suggestion how to get speech-dispatcher up?


On 8/14/2017 1:41 PM, José Vilmar Estácio de Souza wrote:
One thing that you can test is speech-dispatcher.

Run: spd-say 'hello'

At least you will know if speech-dispatcher is working.

On 08/14/2017 12:20 PM, Al Sten-Clanton wrote:
Greetings!  Apologies to anybody who saw a variant of this post on the
Blinux list, but this list seems a reasonable place to ask for help
with at least the Orca part of my problem.

Yesterday, after a fair bit of reading, rereading, and following what
looked like relevant advice from that reading, I ran the upgrade from
jessie to stretch.  I used "apt-get dist-upgrade."  It seemed to be
successful in most respects; it didn't abort, anyway.

When I rebooted, I got what clearly were a bunch of Speakup messages.
Apparently, the upgrade enabled espeakup.service, which I had disabled
in order to run my own script for getting speakup.  At no point did I
get Orca, not even using the super-alt-s keystroke.

When I got myself into a terminal, I tried disabling espeak.servvice.
When I rebooted, there was no speakup, but also no orca; again, the
keystroke to bring it up did not work.

I went into a text terminal, which of course was speechless.  I tried
enabling espeakup.service again, just to get some kind of speech, but
this failed.  I tried a couple more times.  (I know I was in a
terminal because the poweroff command did shut the machine do2wn.)

I suspectt there's this particular thing or two I need to fix, but I
don't know what that is and have no speech anywhere to find out.  At
the very least, I'd like to get Orca talking, and then maybe I can
retrieve my previous speakup set-up.  I'll be grateful for any help.


[p.s. I've read the accessibility section about disabling pulseaudio.
I may do that again, but when I did it the last time it preventing my
listening to an online radio station, hence the script for using
speakup after I was logged in via the gui.  I hope to use speakup with
my Tripletalk LT, but that will come later.
orca-list mailing list
orca-list gnome org
Orca wiki:
Orca documentation:
GNOME Universal Access guide:
Log bugs and feature requests at

Assinatura Informal José Vilmar, Telefones: 21 2555-2650 e 21
98868-0859, Skype: jvilmar

Assinatura Informal José Vilmar, Telefones: 21 2555-2650 e 21
98868-0859, Skype: jvilmar

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]