Re: [orca-list] orca makes qt5 applications extremely unstable (or maybe at-spi ?)


Yes, I think I've understood your explanation this way after reading your first message. My install of pcmanfm does not do this it's why I am wondering what might be different.
I'll play with this a bit more today to figure out.



Dňa 3. decembra 2016 10:37:17 PM používateľ Tyna Pelletier-Bilodeau <ecole tyna gmail com> napísal:

my issue with gtk file managers is probably badly explained... What I
meant was, when I'm in the file view and type a letter to get to the
first file starting by that letter, instead of bringing me there, it
pops a search field where I can type as many letters as I want, and to
get rid of it I need to press the escape key. It is extremely annoying
to me, especially when moving a lot of files around, since I have to
press the escape key and lose some time in doing this. That was my
reason for switching to the qt5 version of pcmanfm. For all I've known,
pcmanfm gtk, caja and nautilus, they all do this, and I *hate* it. I
think this is of course a matter of personnal preference.

Peter Vágner a écrit :

I am using GTK2 based pcmanfm from the arch repositories and I don't
have issues with quick search popups at all.
I prefer  transmission-qt over its GTK based counterpart because by
using transmission-qt, I can launch a local session or connect to
remote transmission daemon within the single app.



Dňa 1. decembra 2016 21:18:56 používateľ "B. Henry"
<burt1iband gmail com> napísal:

I use pcmanfm-git, have used it forever in arch and it does not pop
up anyu search thingy.
There are unfortunately dependency problems, so not sure about
installing to a new system from the AUR, nor if recent  updates to
libfm can be applied
I'm using
pcmanfm-git 1.2.4.r0.gacfa207-1
The libfm-gtk-git is a quite old version, but it still works.
I can certainly always start typing withg the desired result of going
to the item in my working directory starting with said letter or
I will gladly share my packages, and if ther is interest from more
than a couple of people make the package available on my website. I
have a 64bit
machine, not sure how to rebuild for a 32bit box off the top of my
head, but eventually will look in to this as well, or sooner if
someone can tell me how
off list.
I'd be lost with out ppcmanfm.
Problems may occur when adding pcmanfm to a system running gnome or
perhaps even mate, at least at one time it was a bit complicated to
work around other
filemanager(s) depending on another libfm package, think it was
libfm-extra or something based on that name.
I've tried QT versions of several packages that also offered a GTK
front end, and I believe with out exception eventually if not right
away settled on the
GTK package, transmission and deluge torrent clients come to mind,
but there have been a few others.
  Well, I wanted to say I've had no issues with qt apps, but just
tried to   start mumble, have the tts snapshot version from the arch
aur, and nothing.
Tried directly starting the executable as well as using the .desktop
file, nothing, not sure what is going on there. I will try when I
have a chance after
a reboot.
Tried a couple other QT apps with out issue, but wish I could open
app specific settinggs for teamtalk. This has never worked however.
The progressbar
beeps are very annoying as volume levels as maybe other things are
changing, can't remember if latency is displayed or not in teamtalk.

   Registerd Linux User 521886

  Tyna Pelletier-Bilodeau wrote:
Thu, Dec 01, 2016 at 05:28:04AM -0500

recently I've been using pcmanfm-qt from git as my primary file
because they finally switched away from qt4 in their development
due to the fact I was extremely annoyed at every gtk file manager for
popping that useless search bar every time I type a letter instead of
bringing me to the first file starting with that letter. However
I've been
constantly struggling with it, and had to keep the gtk2 version of
nearby for most things (i.e: copy/paste, cut/paste, ...) The
problems here
seem to be hit at random (I can go in a directory, go back from it
crash, but the next time I do that pcmanfm will crash). I think
those are
really important to fix, as none of them happens when orca isn't
running. I
tried using accerciser but it failed, I'm no expert <smiles>. My
distro is
archlinux up to date. For those who want to test (if any), the
package is
pcmanfm-qt-git in the AUR. Also I use orca master up to date as of
orca-list mailing list
orca-list gnome org
Orca wiki:
Orca documentation:
GNOME Universal Access guide:
Log bugs and feature requests at
orca-list mailing list
orca-list gnome org
Orca wiki:
Orca documentation:
GNOME Universal Access guide:
Log bugs and feature requests at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]