Re: [orca-list] gedit: could not open display when using it as root?

Hi Andy,

Hmmm...I'm getting the same behavior here when I tried it on Ubuntu Precise. So your definitely not going crazy. There is something up with gksudo and gedit here.

    On 3/25/2012 3:44 PM, Andy B. wrote:

Try this in Ubuntu 12.04. I do not know if this is an accessibility problem because I could not find much about the problem anywhere online. It seems that when doing:


$sudo gedit /etc/apache2/sites-available/srs


I end up getting:

Gedit: could not open display. Type ‘gedit –help’ for more options.

$gedit test_file

[gedit opens with a blank file]

…after closing gedit…


$gksudo gedit /etc/apache2/sites-available/srs

[gtk window asking for administrator’s password appears. Typing the password and pressing ENTER closes the process with the following in the terminal window]


GTK **warning** (2575): could not find GTK theme in ‘MODULE_PATH’. Pixmap.



Any idea what could be going on? Some website recommended to install gtk2-engines-pixbuf. After doing this I still get the same problem. Could Orca be interfering somehow?

_______________________________________________ orca-list mailing list orca-list gnome org Visit for more information on Orca. The manual is at The FAQ is at Log bugs and feature requests at Find out how to help at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]