Re: [orca-list] trying to putn things in perspective for ff3.6 issue with orca

Here's my current status, and I'm attaching my patch to this e-mail.
The patch is very small, and seems to work well with code I checked
out using Mercurial.  This is basically the 3.7 branch.  The 3.6
branch never worked well for me, and I'm close to abandoning it
entirely, and tempted to skip to 3.7, where things work well for me
after applying the patch.  I'm using my patched firefox to write this
e-mail through the web site.  To duplicate what I have,
download the Firefox source code using Mercurial with this command:

hg clone

Go into the firefox directory, and apply the patch, with:

patch -p1 < ~/Downloads/firefox.patch

Build Mozilla with the instructions on this page:

After installing it, I'm able to run with seemingly decent
accessibility, but make sure Grab Focus is off, while Orca Caret
Navigation is on.  I'm trying to build a package for Ubuntu Lucid (and
Vinux) that is reliable and contains this patch.  However, last
night's daily build of Mozilla for Ubuntu Lucid crashes on many web
pages, even, even when not running Orca.  The code directly
from Mozilla is working fine.   Grrr...


On Sat, Apr 24, 2010 at 6:30 AM, Jason White <jason jasonjgw net> wrote:
hackingKK <hackingkk gmail com> wrote:
Hello all,
I would like to know if we must downgrade to ff3.5 for getting
better accessibility with orca?

Either downgrade to 3.5 or try the patches for 3.6 discussed on this list.
(I'm not sure whether the patches are available yet for testing.)

orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at

Attachment: firefox.patch
Description: Text Data

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]