Re: [orca-list] can't start Orca

Daniel and Jude, thanks for your replies.

I'm sorry to say that I tried the suggested instructions below but got nothing, at least, nothing I could 
use.  I note that I got a beep right after entering the "gnome-terminal" command:  it didn't wait for the 
down-arrow.  In fact, the down-arrow didn't cause a beep at that point, though it did after two uses of the 
alt-tab keys.  At no point did I get orca talking.

Setting DISPLAY to :0 did not help, not even when I included the command in /etc/profile, so that it was set 
to this after boot-up.  the command "echo $DISPLAY" gave me nothing before.  Since you wrote that it also 
gave you nothing, but you apparently can use orca, maybe it doesn't matter.  But if it doesn't matter, of 
course, why have I received error messages saying that it does?

Thanks again, though.  Of course, I welcome any other suggestions for solving this problem.  (I'm beginning 
to fear that this is some quirk of my system, like whatever prevented me from installing FC6 from CD's but 
didn't prevent installation from an image on the hard drive.)

----- Original Message ----- 
From: "Daniel Dalton" <d dalton iinet net au>
To: "Albert E. Sten-Clanton" <albert e sten_clanton verizon net>
Cc: "orca list" <orca-list gnome org>
Sent: Tuesday, January 29, 2008 6:13 AM
Subject: Re: [orca-list] can't start Orca

On Mon, 28 Jan 2008, Albert E. Sten-Clanton wrote:



I'm using Fedora 8.  I had the same trouble with Fedora 7; I didn't try Orca with an earlier version.

In a console, and of course with runlevel 5, I type "orca -t" and go through the setup choices.  When I 
hit the enter key, though, I get "Cannot start Orca because it cannot connect to the Desktop.  Please 
make sure the DISPLAY environment variable has been set."

What does

I've tried logging in via gnome.  I can't tell if I actually am logging in, but something happens, since 
the hard drive spins.  Pressing alt-f2, waiting, and typing orca (or Orca) does nothing, with or without 
the -t.

Hit alt f2
then wait a moment and type "gnome-terminal"
Then hit down arrow.
Do you hear a beep?
If not alt tab and hit down arrow again.
Hopefully it beeps somewhere when you hit down arrow.
This means your in a gnome-terminal.
Now try
orca -t

But orca -t should be really working from a standard console.
So this makes me think that X isn't working correctly...

I forget exactly how, but I was led to see if gdmsetup might help.  That command results only in the 
message "(gdmsetup:2750):Gtk-WARNING **: cannot open display:".

Not sure.

I considered blaming my monitor or its connection to the computer, since nothing showed up on the screen 
using either Fedora 7 or GRML.  (That's why I don't know if what happens is a login or not.) Also, though 
I didn't find much on Google about the DISPLAY variable, one item seemed to concern a possible hardware 
problem.  Still, I used the ubuntu 7.10 live cd, and Orca spoke fine.  I know of course that a new 
monitor's likely in order, but that ubuntu works tells mt, even if this is part of my problem, there's 
more to it.

Ok well it shouldn't have much to do with your monitor.
I don't even have a monitor connected...
Although I did setup with the monitor connected to the right settings for 
my monitor.
But I doubt it is your monitor...

I did try setting the DISPLAY variable manually, using an example from one of my books and the one I got 
by way of the set command while in a terminal in ubuntu.

Ok well if this helps mine is:

Actually echo $DISPLAY says nothing... Why?

I'll be grateful if somebody can tell me what I might do or where I might look for information to solve 
this problem.  Thanks!

Hope some of this helps a little bit.
Sorry I don't really no much about this...

Daniel Dalton
d dalton iinet net au

No virus found in this incoming message.
Checked by AVG Free Edition. 
Version: 7.5.516 / Virus Database: 269.19.15/1249 - Release Date: 1/29/2008 9:51 AM

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]