Re: [orca-list] accessible login

Hi Brian:

Thanks! I think the OpenSUSE folks also ran into the same problem. JP seemed to think this change might have been the source of confusion: This change seemed to go in with I'm not an expert in how various distributions build things, though, so I'm just passing on what I understood.


Brian Cameron wrote:

Some thoughts from the GDM maintainer...

Accessible login appears to be broken on every Linux distribution. As
Will points out, this is an issue with distributions. Nevertheless, it's
a serious issue for accessibility.

I recently worked with Ubuntu to fix their problems with accessibility
so I think their recent releases should be working.  Their problem was
that they install the at-spi-registryd to a non-default location and
they needed to fix the way they call configure to specify the location
of the registry daemon.  This might be a problem for other distros?

There also have been some useful a11y related bug fixes in GDM 2.20,
so I would recommend using the latest & greatest.

The email below discusses Ubuntu. At the Gnome A11y Summit this weekend
we verified that Suse is broken. My own experience indicates that Fedora
7 and Fedora 7.91 are broken.

It would be helpful if people were to file bugs or explain on the
gdm-list gnome org mail list what the problems are.  I'd be happy to
help.  The GDM documentation at the following link has some help
in the "Accessibility" section to explain how to debug some common
accessibility issues with GDM:

Now that our assistive technologies have passed from mostly
developmental software into the realm of usable tools for real people
with disabilities, this situation is no longer tolerable. We must call
on all distributions to institute procedures to insure that accessible
login gets fixed and stays fixed. This will require regular testing, as
there are many ways to break accessible login.

There are some well known bugs/issues with accessibility.  For example,
it doesn't work so well with gdmgreeter and some AT programs.  You
probably need to switch to using gdmlogin if you really need to use an
AT that can interact with the widgets.  gdmgreeter would require some
work to really support accessibility properly.  It's main problem is
the way it uses GnomeCanvas for building the theme, and the fact that
it doesn't support keyboard navigation.

Also, failsafe xterm isn't accessible.  Perhaps GDM should be
configurable so you could use it with gnome-terminal, which does support

gdmsetup is also not accessible, and probably can't be as long as it
requires that you run it as root.


Willie Walker writes:
Hi Guy:

The last time I looked, accessible login was broken on Gutsy. I sent information off to the Ubuntu folks for tracking the problem down, but I'm not sure where they stand with it right now.

There's some information on Accessible Login here:

Hope this helps,


PS - Accessible login does indeed work - I've tested it on OpenSolaris.

Guy Schlosser wrote:
Hey all, how do you enable accessible login in Gutsy? After I updated last night, I now have the login sound, but orca does not start automaticly. Any suggestions? Also, is there something that needs to be done in order to have Orca read items where you have to be root to administer? Finally, one last question. I noticed that firefox 3 was in the Gutsy universe repos. Why isn't that updated after alpha7. Alpha 8 has been released and a9pre is current. Thanks much in advance for any help.



Orca-list mailing list
Orca-list gnome org
Visit for more information on Orca
Orca-list mailing list
Orca-list gnome org
Visit for more information on Orca

gnome-accessibility-list mailing list
gnome-accessibility-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]