Re: Segv on make check in 2.3.100 and 2.3.102

On 2002.01.22 11:54 Mark McLoughlin wrote:
> Hey,
> On Mon, 21 Jan 2002, loz wrote:
> > I'm trying to build the gnome2 desktop alpha. I get the following in
> > test/everything when running make check:
> >
> > make  check-TESTS
> > make[1]: Entering directory `/usr/src/gnome2/ORBit2-2.3.102/test/everything'
> > ././ line 29:   309 Segmentation fault      (core dumped)
> ./server
> > $params
> >
> > I can't figure out how to get gdb to load symbols for this executable -
> > "file server" indicates that the binary is not stripped - but thats as
> far
> > as my knowledge goes.
> 	try 'libtool gdb server core' and then 'bt' to get a backtrace.

I get the same as if I just type gdb server core - a backtrace but no
symbols. for reference (though I doubt it is any use):
This GDB was configured as "i686-pc-linux-gnu"...
Core was generated by `./server --ORBIIOPIPv4=0 --ORBIIOPUSock=1'.
Program terminated with signal 11, Segmentation fault.
#0  0x4000bd5a in ?? ()
(gdb) bt
#0  0x4000bd5a in ?? ()
#1  0x40002abd in ?? ()
#2  0x4000fc55 in ?? ()
#3  0x40002582 in ?? ()
#4  0x4000226a in ?? ()

Is there another library outside of ORBit that I may need to build with
symbols - some of my system libraries are stripped.
> 	Sure, are you having any other problems? Does make check in
> libbonobo pass? What platform is this? Could you send on the
> backtrace?
My platform is i686-pc-linux-gnu (in fact an athlon). My system is all
Linux From Scratch. gcc version 3.0.3, glibc-2.2.3, libtool 1.4. I tend to
build things with CFLAGS="-march=athlon -mcpu=athlon -O2 -g". I've tried
ORBit without the "m" flags, and without any flags over the default. I've
also tried outside of a gnome-1.4 session.
Make check in libbonobo passes OK. As a side note - make check in
bonobo-activation only worked after I had done a make install (maybe as
well as copying the broken.server file).



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]