Network Manager + ovsdb issues


I am seeing two issues with NM and ovsdb. Issue # 2 is more critical.

In my configuration, I have two bridges in OVS. On one of the bridge, the interface needs to be under Network Manager, so I have changed commands to:

nmcli conn add type ovs-bridge conn.interface
nmcli conn add type ovs-port conn.interface
nmcli conn add type ovs-interface slave-type ovs-port conn.interface
nmcli conn add type ethernet conn.interface

On the other bridge, I am still using, e.g. 

ovs-vsctl --timeout=5 add-br

Also, there are a bunch of places where ovs-vsctl is used for reading, e.g.

ovs-vsctl list-ports

The issues I am seeing are:

(1) For Interface/ports created via nmcli, sometimes I have issue deleting them:

I see the config file in /etc/NetworkManager/system-connections/ovs-slave-port1

nmcli c delete ovs-slave-port1

I get something like, this device does not exist (I have seen this error once)

Following is a more important issue

(2) In some situations, commands like the following would timeout:

ovs-vsctl --timeout=5 add-port bridge1 port1

If I run the above command without --timeout, this will never return. However, if I let it timeout or ctrl-c and use ovs-vsctl show, it shows that port1 is created.

I ran this under strace and saw ovs-vsctl is stuck at poll call. I have also seen 

cat ovsdb-server.log
2021-05-24T14:13:11.930Z|00003|reconnect|INFO|unix:/var/run/vmware/nsx-agent/nsxagent_ovsdb.sock: connecting...
2021-05-24T14:13:11.930Z|00004|reconnect|INFO|unix:/var/run/vmware/nsx-agent/nsxagent_ovsdb.sock: connection attempt failed (No such file or directory)

It connects fine when using ovs-vsctl show


1. Is it okay to use both nmcli and ovs-vsctl to create bridges/ports/interfaces (when they are under different bridges)?

2. Have anyone seen these errors?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]