Re: Network Manager + ovsdb issues


On Mon, 2021-05-24 at 14:35 -0700, Abu Rasheda via networkmanager-list

I am seeing two issues with NM and ovsdb. Issue # 2 is more critical.

In my configuration, I have two bridges in OVS. On one of the bridge,
the interface needs to be under Network Manager, so I have changed
commands to:

nmcli conn add type ovs-bridge conn.interface
nmcli conn add type ovs-port conn.interface
nmcli conn add type ovs-interface slave-type ovs-port conn.interface
nmcli conn add type ethernet conn.interface

these commands are not complete and not working. Could you share the
full commands?

also, after you created the profiles (an activate them), what gives
`nmcli connection`, `nmcli device` and `ovs-vsctl show` ?

On the other bridge, I am still using, e.g. 

ovs-vsctl --timeout=5 add-br

Also, there are a bunch of places where ovs-vsctl is used for reading,

ovs-vsctl list-ports

The issues I am seeing are:

(1) For Interface/ports created via nmcli, sometimes I have issue
deleting them:

I see the config file in /etc/NetworkManager/system-connections/ovs-

nmcli c delete ovs-slave-port1

I get something like, this device does not exist (I have seen this
error once)

This merely deletes a profile in NetworkManager. This always should
succeed, and there is no reason why it can fail (except bugs). But
there is not enough information provided, to understand what exactly
fails. The message "device does not exist" doesn't make sense for this
command. Please share the literal error messages by quoting them, not

Also, please always collect `level=TRACE` logs of NetworkManager. See
for hints about logging.

Following is a more important issue

(2) In some situations, commands like the following would timeout:

ovs-vsctl --timeout=5 add-port bridge1 port1

If I run the above command without --timeout, this will never return.
However, if I let it timeout or ctrl-c and use ovs-vsctl show, it
shows that port1 is created.

Are "bridge1" and "port1" the actual names, or is this an example?

I ran this under strace and saw ovs-vsctl is stuck at poll call. I
have also seen 

cat ovsdb-server.log
agent/nsxagent_ovsdb.sock: connecting...
agent/nsxagent_ovsdb.sock: connection attempt failed (No such file or

I am no tfamiliar with OVS, but this doesn't seem relevant. Is
something else in those logs?

It connects fine when using ovs-vsctl show


1. Is it okay to use both nmcli and ovs-vsctl to create
bridges/ports/interfaces (when they are under different bridges)?

yes (presumably)

did you test that not using NetworkManager in parallel avoids the
NetworkManager talks directly to ovsdb, like ovsvs-ctl does. Deactivate
all OVS profiles in NetworkManager (check `nmcli connnection` and
`nmcli conneciton down "$PROFILE"`). Then also check that nothing is
left over in ovsdb from NetworkManager (with `ovs-vsctl show`). Then
perform the steps on the other bridge. Do they work?

2. Have anyone seen these errors?

I didn't.


Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]