Re: Option HSO device + NetworkManager 0.7

On Wed, 2008-10-08 at 22:27 +0100, Jonathan McDowell wrote:
> On Wed, Oct 08, 2008 at 12:14:25PM -0400, Dan Williams wrote:
> > On Tue, 2008-10-07 at 23:10 +0100, Jonathan McDowell wrote:
> > > I have an Option Icon 225 (provided by Orange in the UK). I'm currently
> > > using it with HSOConnect and a 2.6.27-rc8 kernel with the hso kernel
> > > driver. However I'd like to get it working with Network Manager as that
> > > seems like a much cleaner solution.
> > > 
> > > I'm running Debian testing and have compiled up the pkg-utopia packages
> > > of NetworkManager (svn r4142) and network-manager-applet (svn r920).
> > > That gives me a control panel regarding PPP connections, but plugging in
> > > the USB dongle doesn't result in NM doing anything. I've tried
> > > installing the Option provided udev bits that include some HAL scripts
> > > regarding the modem. That makes NM show the device is available, but
> > > clicking on it seems to result in PPP being invoked and failing.
> > > 
> > > My understanding (and experience with HSOConnect) is that PPP shouldn't
> > > be involved at all for this device. What am I missing in terms of
> > > getting it running under NM? I had a look at recent hal-info git but
> > > couldn't see anything obvious?
> > 
> > Correct, PPP doesn't get invoked at all with these devices.  Can you
> > provide some log output from /var/log/messages or /var/log/daemon.log
> > that shows where you plug in the device and where NM recognizes it?
> > 
> > You need the udev rules to eject the ZeroCD mass storage device that
> > always pops up when you plug the thing in, but after that you'll get the
> > serial devices that are needed to control the dongle.  Once you've tried
> > to connect, grab logs from the aforementioned places and reply to this
> > message with them.
> Ok, reading the source further and peering at lshal has led me to the
> conclusion that it was the hal-info data that was missing. Dropping the
> attached file in /usr/share/hal/fdi/information/10freedesktop/ leads to
> success. Without the file, nothing happens. With the version from wader
> (which neglects the serial.port test) 2 ttyHS? files are treated as
> valid devices, which causes some confusion. With the hal-info file from
> hso-udev (which contains the ozerocdoff tool) the tty device that
> advertises the GSM command set doesn't have the same parent as the hso0
> network device, so it's just treated as a normal GSM modem (hence the
> call to PPP when I first tried).

Yeah, they tty and the netdev need to have the same parent device (NM
checks for this), which should just happen with the 2.6.27 hso driver
and no additional stuff.  What's missing then is the autoprobing to
determine which port is the real TTY.  You can work around that by using
the hal-info rules.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]