Re: NM fails to find access points

No it isn't found at all when the bug is in effect. Doing "Create new.." dance makes it show up again.

I tried many times. But it doesn't show up.

That points more to a driver bug then.  What kernel version, what
distro, and are you using the stock distro's driver or did you compile
your own from somewhere?


Could very well be, since restarting NM on one of my other laptops
doesn't result in a loss of APs. That laptop is using a 3945ABG chip and
is also running the latest fedora development updates.

I'm using fedora rawhide with the latest updates applied.
kernel 2.6.25-0.172.rc7.git4.fc9.i686
iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.26kds

I just tested that it works with kernel-2.6.25-0.95.rc4.fc9.i686.
I also retested with the lastest kernel since that had a lot of iwlwifi updates. It still doesn't work after restarting NM.

I've haven't compiled any of this myself. It is all from the development

The laptop is a lenovo thinkpad T61p.

lsusb -vvv output of the wireless device:

03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or
AGN Network Connection (rev 61)
	Subsystem: Intel Corporation Lenovo ThinkPad T61
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 215
	Region 0: Memory at df2fe000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
		Address: 00000000fee0100c  Data: 4172
	Capabilities: [e0] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 128 bytes
		DevSta:	CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr+ TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0
<128ns, L1 <64us
			ClockPM+ Suprise- LLActRep- BwNot-
		LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive-
BWMgmt- ABWMgmt-
	Capabilities: [100] Advanced Error Reporting <?>
	Capabilities: [140] Device Serial Number 39-32-47-ff-ff-e8-13-00
	Kernel driver in use: iwl4965
	Kernel modules: iwl4965

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]