Re: NM fails to find access points

Dan Williams wrote:
On Thu, 2008-03-27 at 20:28 +0100, René Rask wrote:
I can replicate this reliably by restarting the NM daemon. That always
 >> leaves my AP off the list. I can also reliably find my AP again by using
 >> "Create Net Wireless Network". When the new network fails to connect it
 >> will always show my AP (and the rest of them) again. Sometimes it takes
 >> a short while for it to appear, but it always does. Seems like a
 >> scanning delay.
 >> Stopping NM, removing the wireless kernel module, insmod it and starting
 >> NM again also has the effect of making it find my AP again.
 > So this is pointing more towards a driver problem.  If you ever have to
 > rmmod/insmod and stuff starts magically working again, it is almost
 > always a driver issue.
 > One more question: does your AP almost always show with 'iwlist', but
 > usually never when doing the dbus-send to the supplicant?
 > You might also try to do an 'iwlist' and then right afterwards, poke the
 > supplicant with the dbus-send command and see if your AP is in the list.
 > If the iwconfig and the supplicant-reported APs are quite different,
 > then the supplicant is the problem.
 > If you can poke around a bit with these things, let me know what happens
 > so we can narrow down the issue further.

I can't get this to work anymore. Last time wpa_supplicant wasn't started a bootup so I started it manually.

[root rr-laptop ~]# dbus-send --system --dest=fi.epitest.hostap.WPASupplicant --print-reply /fi/epitest/hostap/WPASupplicant/Interfaces/1 fi.epitest.hostap.WPASupplicant.Interface.scanResults Error org.freedesktop.DBus.Error.UnknownMethod: Method "scanResults" with signature "" on interface "fi.epitest.hostap.WPASupplicant.Interface" doesn't exist

I can't restart wpa_supplicant unless I stop NM first. And I still can get the dbus command to work.

(a while later..)
Hmm... now it works again. I was rmmodding/insmodding the iwl4965 modul with debug and other paramaters and stopping/starting NM while this happened.

iwlist scan and the supplicant list match pretty good. Having the same number of APs after a iwlist scan.

iwlist doesn't always show my AP an neither does supplicant. But they seem to agree on showing the same APs. The list of AP also goes from 3 to 14 found and anything in between.
The scans have no effect on what is show in the applet.

When the bug is in effect the number of found APs is 4-8 and my AP isn't found by NM or supplicant.

But it _is_ seen by iwlist?  If it's not seen by iwlist either, then
it's a driver bug.  It's important to note that not every AP will be in
the scan results every time, because wireless is just hard and not
reliable.  However, I would certainly expect a non-hidden AP to show up
after 2 or 3 back-to-back scans at most.

No it isn't found at all when the bug is in effect. Doing "Create new.." dance makes it show up again.

I tried many times. But it doesn't show up.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]