Re: Some questions -- more radio misshaps

 I am going to have to check my bios settings again. Almost like they

Robert Moskowitz wrote:
Dan Williams wrote:
On Mon, 2008-03-10 at 08:19 -0400, Robert Moskowitz wrote:
Hello, I am new here. Running 0.6.4 in Centos 5.1 on an HP nc2400 notebook with the Intel ipw3945 dkms code from rpmforge.

I just switched my operation over the this nc2400 from my old nc4010 which had an Atheros card using the madwifi dkms code from rpmforge and I did everything via wpa_supplicant.conf (and the wpa_cli program!).

So with this install, I could not get the wpa_supplicant working. Seems like it only supports the ipw2200 card? And I found NetworkManager; good job! So far :)
As Ryan pointed out, NM will work with any card that properly supports
wireless extensions.  For RHEL5 (because the kernel is slightly older)
that means ipw3945 (_not_ iwl3945), iwl4965 (as a tech preview only),
airo, orinoco/hostap, atmel, ipw2100, ipw2200, ipw2915, zd1201, and

I am plowing through the archives to find answers, but this is slow! No way that I can find to download them and import them into Thunderbird for better searching. So here goes:

The nc2400 expects the OS to manage the card. There are no buttons to turn the radio on and off like on my old nc4010. Here I am on a plane with the radio on. Now I work with Boeing people (and work on 802.11 standards), so I have some inside knowledge of 802.11 and airplanes in flight, but that is not the point. The radio is eating power! I need that battery life! How can I turn off the radio. I tried iwconfig eth1 power on (to turn on power management), but the card is still happily scanning for APs, I think.
If you uncheck "Wireless Enabled" after right-clicking the applet, this
should down the interface, which if the driver is correctly written
(some are not), should turn off the wireless power to the card.  If your
card doesn't turn off the TX power when you run 'iwconfig eth1 down'
then it's a driver bug.
No such command as iwconfig eth1 down.  You mean ifconfig eth1 down?

I just went trough a 'farrowing' time with this. Everything wireless stopped. So I tried this.
This time when things stopped working I looked first before typing.
Radio went off. I had unplugged the notebook and closed the unit. But I
have done that earlier today. I plugged back in and while I was doing
lsmod and dmesg commands, the radio came back on. More likely not
related, just with power it 'woke up'? ARGH.
I could not get the wireless back up. Rebooted a number of times. No wireless at all!

Then the LED came on and things started working after I did a dmesg command, which makes no sense that that turned the radio on. Could just have been a heat glitch. But in all this I learned that iwconfig eth1 down is not a valid command :)

One of the joys of a meeting like the IETF is there are lots of APs visable with lots of clients around and all sorts of nonsense to make wireless go bump in the middle of a lookup. IEEE 802.11 meetings are just as bad! Interop has been worst (all those vendors running their own wireless demo network). If you want to test out your code, go to a big conference or trade show!

I seem to recall a way with lmsensor to turn the LEDs on and off, but I think that only tied the LEDs into the reality of the operation of the card, not impacting the card at all.

This notebook also has builtin ethernet. But shortly I will be at the IETF conference in Philly, and I want to run Firestarter with its NATing functions so I can plug another computer into the notebook to give it access through my one wireless connection. How can I get NetworkManager to leave the wired alone so Firestarter can manage it and run services like DHCP?
Add the line "NM_CONTROLLED=no" to
your /etc/sysconfig/network-scripts/ifcfg-eth0 (or whatever interface
name your wired card is) and NetworkManager will ignore it.  NM will
still manage the default route then when wireless is enabled and active.

My home network runs WPA-PSK (yeah, I know the risks, I wrote the attack paper, but my Radius server is currently down). I frequently run into the situation where NetworkManager is not succeeding in authenticating to the AP. I have no sniffing data; I would like to see some packets, but Wireshark does not show interface eth1 (the wireless one). I end up having to reboot to get wireless working, or switch to wired.
You probably have to switch the ipw3945 into monitor mode; if you google
around you can probably find out how, but I think it includes inserting
the ipw3945 module with the "rtap_iface=1" argument, then 'ifconfig
rtap0 up' and then using wireshark.

Now I notice that my AP is on channel 1, and I am picking up "Oakland Wireless" also on channel 1. This should NOT be causing the problem (I hope), but I add the data point. Actually I would like the option to tell NetworkManager to ignore "Oakland Wireless" when I am at home, just not when I am over at the local park, come springtime. When I used wpa_supplicant.conf, I could comment out various configs (or uncomment them) and reload the conf file at least. Ah the pains of a real nice integrated gui!
NetworkManager will attempt to connect to the network you last used (via
a timestamp of the last successful connection).


NetworkManager-list mailing list
NetworkManager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]