nm-applet randomly fighting with dbus

Recently (in the past few days) and for no apparent reason (no update
I can remember, only removing kubuntu-desktop), nm-applet gives me
this when I start it:

** (nm-applet:12061): WARNING **: <WARN>  nma_dbus_init(): could not
acquire its service.  dbus_bus_acquire_service() says: 'Connection
":1.22" is not allowed to own the service
"org.freedesktop.NetworkManagerInfo" due to security policies in the
configuration file

I've changed the /etc/dbus-1/system.d/NetworkManager.conf file so that
it allows in all cases, but it doesn't work. I've also tried nm-applet
--sm-disable, but when I run nm-applet as root, it runs right off the
bat and connects fine. A little googling told me to do what I had
already done (edit the conf file), so I tried it again (crossing my
fingers) to no avail.

Can anyone suggest anything?


Peter Davoust (worldgnat gmail com)

"Don't mistake your watermelon for the universe"
-Kenn Amdahl

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]