Re: Explanation of killswitch related messages.

On 9/20/07, Aaron Konstam <akonstam sbcglobal net> wrote:
> Things got much clearer to me when I ran:
> dellWirelessCtl -i

This is what I get on my Dell Latitude X1 (using the ipw2200 driver):

# dellWirelessCtl -i
Libsmbios version      : 0.13.10
dellWirelessCtl version: 0.3.0
Wireless Info not supported on this system.

Wireless Switch Configuration not available on this system.

BIOS Boot-time settings (new interface):
        Wireless_Switch_Cellular_Control_Enable: (NOT SUPPORTED)
        Wireless_Switch_Cellular_Control_Disable: (NOT SUPPORTED)
        Wireless_Switch_Bluetooth_Control_Enable: (NOT SUPPORTED)
        Wireless_Switch_Bluetooth_Control_Disable: (NOT SUPPORTED)
        Wireless_Switch_Wireless_LAN_Control_Enable: (NOT SUPPORTED)
        Wireless_Switch_Wireless_LAN_Control_Disable: (NOT SUPPORTED)
        WiFi_Locator_Enable: (NOT SUPPORTED)
        WiFi_Locator_Disable: (NOT SUPPORTED)
        Cellular_Radio_Enable: (NOT SUPPORTED)
        Cellular_Radio_Disable: (NOT SUPPORTED)
        Bluetooth_Devices_Enable: 0
        Bluetooth_Devices_Disable: 1
        Wireless_LAN_Enable: (NOT SUPPORTED)
        Wireless_LAN_Disable: (NOT SUPPORTED)

BIOS Boot-time settings (old interface):
        Radio_Transmission_Enable: 1
        Radio_Transmission_Disable: 0
        Wireless_Device_Disable: 0
        Wireless_Device_App_Control: 0
        Wireless_Device_App_Or_Hotkey_Control: 1

So I guess NetworkManager should check for this, and stop spitting out
all this messages.

best regards,

PS: I run a really old A02 BIOS on my X1, as the newer versions will
lock the laptop at 600MHz after half an hour usage (normal is 1.1
GHz). I have contacted Dell about that problem, and given extensive
debugging data, but got no response back.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]