Re: Explanation of killswitch related messages.

On Wed, 2007-09-19 at 21:10 +0200, MartinG wrote:
> Similar problem here, on a Dell Latitude X1:
> # uname -a
> Linux x1 #1 SMP Thu Aug 30 13:47:21 EDT 2007 i686 i686
> i386 GNU/Linux
> # cat /etc/rc.local
> #!/bin/sh
> touch /var/lock/subsys/local
> modprobe cpufreq-powersave
> modprobe  dcdbas
> service haldaemon restart
> # lsmod|grep dcdbas
> dcdbas                 12257  0
> # tail /var/log/messages
> Sep 19 20:08:28 x1 NetworkManager: < info >  Error getting killswitch
> power: org.freedesktop.Hal.Device.KillSwitch.NotSupported - Access
> type not supported
> Sep 19 20:09:04 x1 last message repeated 6 times
> Sep 19 20:10:10 x1 last message repeated 11 times
> ...
> # rpm -q libsmbios-bin
> (not installed)
> So I went ahead and installed it:
> # wget -q -O - | bash
> (what a stupid way to install a yum repo! Piping a web-page to bash...
> I actually saved the script, and had a brief look at it before I ran
> it.)

Now I have really fouled UP:
I have a dell Latitude D810
I installed the modprobe dcdbas
I installed libsmbios  using the  wget above.
 /usr/bin/dellWirelessCtl --version produces no meaningfull result. 
/usr/bin/dellWirelessCtl  does not exist.

I have noting in BIOS that calls itself a killswitch but there is an
option to turn wireless on and off using Fn-F2. I assume that is the
software killswitch.

I still get the killswitch related messages in /var/log/messages.

Now I made a big mistake . I decided to re-install libsmbios . So I
removed it and tried the wget method again to reinstall it. That did not
work. I got a message this was already done and it will not be done

So I haven't installed libsmbios and the errors are still there. What
worries me is that somewhere along the line I got a message that
libsmbios is needed by the haldaemon.

Anny help out there?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]