Re: Reconnect problems with 0.6.5

On Tue, 2007-05-08 at 17:12 -0400, Jon Nettleton wrote:
> I have no idea what this is related to yet.  I run a prism54 mini-pci
> card that since this last rawhide update ( NetworkManager 0.6.5 ) can
> only handle the initial connection.  If I manually attempt to choose
> another wireless network it just spins and spins until it asks for a key
> ( that it already knows ), then spins until it completely times out.
> I tracked down the problem and found it to be that on reconnect the
> wireless interface was never being brought back up.  So simply running
> the command ip link set eth1 up, allowed the wireless to reconnect and
> all was happy.  So this means that in
> nm_device_activate_stage2_device_config () nm_device_is_up is failing to
> report back correctly.  With some debug output later sure enough, even
> though link was showing down from ip link show, NetworkManager was
> reporting that link was up.  I find this strange because both methods
> use virtually identical code.
> Some more debugging later and I added a sleep for a bit if
> nm_device_is_up reports true, so I could check things by hand while
> NetworkManager was deadlocked.  The problem disappeared.  I dropped the
> sleep time down to 1 and the problem was still not there.
> Any ideas?  I can clean up my debug output and send it in if you think
> it will help.  Not sure if this is related to any of the other reconnect
> problems either. 

I did a clean Fedora 7 Test 4 last and once again had the wireless
reconnect problems.  Interesting enough I was now getting random
disconnects and timeouts as well.  I recompiled NetworkManager with my
stupid sleep patch again and everything has been fine.  I have cleaned
up logs now, where you can actually see the NETDEV kernel message in the
logs when NetworkManager hits my sleep statement.  Definitely seems to
be a timing problem, don't know if it is in the prism54 driver or
NetworkManager yet.

Attached are my patch and both logs.

It might be useful if the guys having the long reconnect problems try my
patch out.  Could help narrow down the problems.


Attachment: NetworkManager-0.6.5-device-link-race.patch.gz
Description: GNU Zip compressed data

Attachment: failed-connect.log.gz
Description: GNU Zip compressed data

Attachment: successful-connect.log.gz
Description: GNU Zip compressed data

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]