Reconnect problems with 0.6.5

I have no idea what this is related to yet.  I run a prism54 mini-pci
card that since this last rawhide update ( NetworkManager 0.6.5 ) can
only handle the initial connection.  If I manually attempt to choose
another wireless network it just spins and spins until it asks for a key
( that it already knows ), then spins until it completely times out.

I tracked down the problem and found it to be that on reconnect the
wireless interface was never being brought back up.  So simply running
the command ip link set eth1 up, allowed the wireless to reconnect and
all was happy.  So this means that in
nm_device_activate_stage2_device_config () nm_device_is_up is failing to
report back correctly.  With some debug output later sure enough, even
though link was showing down from ip link show, NetworkManager was
reporting that link was up.  I find this strange because both methods
use virtually identical code.

Some more debugging later and I added a sleep for a bit if
nm_device_is_up reports true, so I could check things by hand while
NetworkManager was deadlocked.  The problem disappeared.  I dropped the
sleep time down to 1 and the problem was still not there.

Any ideas?  I can clean up my debug output and send it in if you think
it will help.  Not sure if this is related to any of the other reconnect
problems either. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]