Re: nm-applet suddenly offers no options


First, I would rule out driver problems by attempting to connect to an open or WEP network with the network utility originally used in Ubuntu.  Since you can connect to your home network, this seems unlikely to be a driver problem. 

You also mention ath0/wifi0 - do you have 2 wireless devices?

The commands "ifconfig" and "iwconfig" may give useful information too.

It sounds like you are connecting to the networks (at least partially?) though - is that through network manager or another utility?

Once in awhile my nm-applet does something similar, but it usually works after re-enabling networking.

On a final note, have you tried re-installing network manager?  The wireless drivers?

Sorry I couldn't be of more assistance,

On 2/26/07, Peter Flynn <peter silmaril ie> wrote:
Seth Howard wrote:
> There is a quirk in ubuntu (I think it will be "fixed" with feisty)
> that doesn't allow network-manager to see devices that are listed in
> /etc/network/interfaces.

Cute design idea :-)

> Try commenting out all lines EXCEPT (this is important - you will
> have an unbootable system if these lines aren't there):
> auto lo
> iface lo inet loopback

Thanks...I've tried all permutations of commenting out lines, doing an
/etc/init.d/network restart and HUPping NM, but nm-applet still
stubbornly refuses to admit that *any* network interface exists.

With judicious uncommenting I can get eth0 to work over CAT5 into my
router, natch. Trying to use ath0/wifi0 shows the DHCP request being
granted a lease, but any attempt at connecting from an application
gets a timeout. Even trying to ping the router (the very one that
granted the lease) gets a sendmsg: Operation not permitted.

> That has worked for me in the past. But if for some reason it doesn't
> work, you can always uncomment the other lines and try something
> else.

This is rather baffling, especially as it was all working perfectly
three days ago. Enlightenment was the only intruder. I wonder what piece
of binary randomness it introduced which slew NM?

NetworkManager-list mailing list
NetworkManager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]