Re: nm-applet suddenly offers no options

Seth Howard wrote:
There is a quirk in ubuntu (I think it will be "fixed" with feisty)
that doesn't allow network-manager to see devices that are listed in /etc/network/interfaces.

Cute design idea :-)

Try commenting out all lines EXCEPT (this is important - you will
have an unbootable system if these lines aren't there):

auto lo
iface lo inet loopback

Thanks...I've tried all permutations of commenting out lines, doing an
/etc/init.d/network restart and HUPping NM, but nm-applet still
stubbornly refuses to admit that *any* network interface exists.

With judicious uncommenting I can get eth0 to work over CAT5 into my
router, natch. Trying to use ath0/wifi0 shows the DHCP request being
granted a lease, but any attempt at connecting from an application
gets a timeout. Even trying to ping the router (the very one that granted the lease) gets a sendmsg: Operation not permitted.

That has worked for me in the past. But if for some reason it doesn't
work, you can always uncomment the other lines and try something

This is rather baffling, especially as it was all working perfectly three days ago. Enlightenment was the only intruder. I wonder what piece of binary randomness it introduced which slew NM?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]