Re: Autostarting NetworkManager in Fedora 8 prevents sshd to start properly

On Mon, 2007-12-31 at 00:47 +0100, Robert Allerstorfer wrote:
> On Sat, 29 Dec 2007, 17:32 GMT+00 Rui Tiago Matos wrote:
> > Forget about it. I think Dan misunderstood you. From your original
> > posting you are basically saying that your machine isn't IP
> > addressable until someone logs in which is the normal behaviour of NM.
> > Until NM gains the ability to do system wide configurations (i.e.
> > before anyone starts its applet) you better not use it if you want to
> > access your machine remotely. Period.
> OK - the NetworkManager service thus should currently NOT be set
> autostarted on Fedora 8 using NM 0.7 svn3109. I cannot start NM at all
> to get a wireless WPA2-personal connection with my BCM 4306 card. If
> NM is started, wpa_supplicant 0.5.7 fails to associate with the AP.

What do you mean here?  NM handles all interaction with the supplicant;
if you're using NetworkManager you don't need to configure or run a
separate copy of the supplicant (and in fact NM will use the running
copy if it was started with the -u option and is present on the system

NetworkManager and manual configuration with system-config-network
and /etc/sysconfig/network-scripts/ifcfg-* are mutually exclusive.

> Both of these problems are new with Fedora 8 using NM 0.7 - in Fedora
> 7 using NM 0.6.5 that worked.
> So it really looks like these problems are caused by the NM 0.7
> development version Fedora 8 is trying to use. Is there any newer
> version of NM known to have these problems solved? There is svn3138 in
> Fedora's updates-testing repo since Dec. 7, 2007.

There's going to be another drop when I get back in the office later
this coming week; but that won't yet solve the
networking-on-startup-before-login issue, if that's what you need
working.  That's being worked on as we speak but is not ready yet.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]