Re: Problems solved, well, almost

On Mon, 2006-02-13 at 07:36 +0100, Michael Biebl wrote:
> Dan Williams wrote:
> > On Tue, 2006-02-07 at 20:14 -0500, Ryan Skadberg wrote:
> >> Problem A:
> >>
> >> I was seeing these dbus errors:
> >>
> >> NetworkManager: <WARNING>        nm_dbus_get_network_data_cb ():
> >> nm_dbus_get_network_data_cb(): dbus returned an error.
> >>   (org.freedesktop.NetworkManagerInfo.InvalidArguments)
> >> nmi_dbus_get_network_properties called with invalid arguments.
> >>
> >> After playing around a bit, I realized these were being caused by all
> >> the old APs in gconf.  Once I erased them in gconf's
> >> system/networking/wireless directory, these errors went away.  May be
> >> something to look in to, maybe we need to convert old APs?
> > 
> > Ran into this issue the other day, it appears that earlier version
> > didn't have the 'key_type' parameter, which we use to validate the
> > entry.  I'm not entirely sure how to proceed here, but it's not that
> > hard of a problem.
> > 
> >> Problem B:
> >>
> >> No connection to my AP.  :(  So, I tried doing a standard ifup and
> >> then using NetworkManager and looked at the iwconfig output.  When I
> >> did this, I saw this with ifup:
> > 
> > What distribution?  Are you using NM from CVS?  What wpa_supplicant
> > version are you using?  What card and driver again?  Is it still the
> > 3-year-old Linksys you mentioned from the "Activation too long" thread?
> > 
> > There's an error in wpa_supplicant right now (though I've patched it in
> > Fedora Core rawhide) that prevents wpa_supplicant from setting the
> > correct auth mode on cards & drivers that don't support ENCODEEXT and
> > AUTH extensions.  This might be your problem.
> > 
> >*checkout*/devel/wpa_supplicant/wpa_supplicant-auth-fallback-v3.patch
> Very interesting. I also had the problem, that I got this "Activation
> took too long" messages, regardless how high I set the timeout.
> I used the latest NM from CVS, the ipw2100 driver (kernel 2.6.16-rc2)
> and wpa_supplicant-0.5.1. The wlan access point was a SMC 2804WBR. I
> don't know exactly but I guess it is also something like three years
> old. I couldn't get a connection with NM while running wpa_supplicant
> directly it worked (although it sometimes takes very long >>1min).
> With a newer access point NM works fine.
> After reading your post I decided to apply this patch and test the old
> access point again, and voila, it worked.
> Dan, could this be a common problem of many older wlan access points?
> And do you intend to send this patch for wpa_supplicant upstream?

I've sent it upstream, but Jouni was "thinking about it" for a bit.
I'll ping him again and see what he says...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]