Re: Problems solved, well, almost

On Tue, 2006-02-07 at 20:14 -0500, Ryan Skadberg wrote:
> Problem A:
> I was seeing these dbus errors:
> NetworkManager: <WARNING>        nm_dbus_get_network_data_cb ():
> nm_dbus_get_network_data_cb(): dbus returned an error.
>   (org.freedesktop.NetworkManagerInfo.InvalidArguments)
> nmi_dbus_get_network_properties called with invalid arguments.
> After playing around a bit, I realized these were being caused by all
> the old APs in gconf.  Once I erased them in gconf's
> system/networking/wireless directory, these errors went away.  May be
> something to look in to, maybe we need to convert old APs?

Ran into this issue the other day, it appears that earlier version
didn't have the 'key_type' parameter, which we use to validate the
entry.  I'm not entirely sure how to proceed here, but it's not that
hard of a problem.

> Problem B:
> No connection to my AP.  :(  So, I tried doing a standard ifup and
> then using NetworkManager and looked at the iwconfig output.  When I
> did this, I saw this with ifup:

What distribution?  Are you using NM from CVS?  What wpa_supplicant
version are you using?  What card and driver again?  Is it still the
3-year-old Linksys you mentioned from the "Activation too long" thread?

There's an error in wpa_supplicant right now (though I've patched it in
Fedora Core rawhide) that prevents wpa_supplicant from setting the
correct auth mode on cards & drivers that don't support ENCODEEXT and
AUTH extensions.  This might be your problem.*checkout*/devel/wpa_supplicant/wpa_supplicant-auth-fallback-v3.patch


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]