Re: Method "getActiveDevice" doesn't exist

On Fri, 20 May 2005, Bastien Nocera wrote:
> On Fri, 2005-05-20 at 16:10 -0400, Dan Williams wrote:
> > On Fri, 2005-05-20 at 20:32 +0100, Bastien Nocera wrote:
> > > Hey Dan,
> <snip>
> > > How can I debug the notification icon, to know why it's saying I don't
> > > have any devices?
> > 
> > First of all, you're sure you're running 'nm-applet' ?
> Yup. I tried to though, and it just won't lock the vpn icon, or the
> progress ones (patch for better error reporting below).
> So, how do I debug the notification area stuff then?
> > Second, the nmtest tool is actually wrong, I never fixed it up after the
> > removal of getActiveDevice.  I'll have to do that.
> Right, but still, it lists the devices and networks, and the
> NetworkManagerInfo doesn't.

Put an fprintf() before the dbus_pending_call_set_notify() call in 
nmwa_dbus_update_nm_state() in applet-dbus-devices.c.  That will tell you if the 
applet is even talking to NetworkManager.  Are you sure you restarted the 
messagebus daemon after installing the new copy of NetworkManager from CVS?  If 
not, dbus won't be aware of the applet's security policy and the applet will 
simply get kicked off the bus.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]