Re: [PATCH] - Add drag drop of bookmarks to places sidebar

On Wed, 2005-07-13 at 10:55 +0100, Jamie McCracken wrote:
> Alexander Larsson wrote:
> > I don't like the name "user data" for something that only contains
> > volumes. It would be better to just call it volumes. That way you can
> > correctly own the volume to, and don't have to use the unref_volumes
> > hack before gtk_list_store_clear and other places.
> its called user_data cause it will either contain a volume or a bookmark 
> pointer. I need it to get at the underlying object for the popup context 
> menu which im currently implementing. Is that okay then?

No. Make it two entries in the list instead.

> Can you clarify what you mean by correctly owning the volume? Wont I 
> still have to manually unref it prior to clearing the list store?

No, if you tell the list store it contains a type that is a gobject it
will correctly handle refcounting. This was actually one of the sources
of leaks in your original patch.

 Alexander Larsson                                            Red Hat, Inc 
                   alexl redhat com    alla lysator liu se 
He's an all-American devious senator haunted by memories of 'Nam. She's a 
psychotic hypochondriac advertising executive with the soul of a mighty 
warrior. They fight crime! 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]