Re: [PATCH] - Add drag drop of bookmarks to places sidebar

Alexander Larsson wrote:

I don't like the name "user data" for something that only contains
volumes. It would be better to just call it volumes. That way you can
correctly own the volume to, and don't have to use the unref_volumes
hack before gtk_list_store_clear and other places.

its called user_data cause it will either contain a volume or a bookmark pointer. I need it to get at the underlying object for the popup context menu which im currently implementing. Is that okay then?

Can you clarify what you mean by correctly owning the volume? Wont I still have to manually unref it prior to clearing the list store?

Mr Jamie McCracken

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]