Re: Meld failed on git repo

On 9 January 2013 09:43, Peter Olson <peter olson gmail com> wrote:
> On Mon, Jan 7, 2013 at 11:26 AM, Kai Willadsen <kai willadsen gmail com> wrote:
>> Yeah that's weird. That version of Git is certainly untested, but I'm
>> not aware of any breaking changes. If you'd like to try the current
>> HEAD version of Meld, I'm pretty sure it will work for you. If not,
>> I'd definitely like to hear about it.
> Running HEAD version took be a bit before I realized that as I'm in
> ArchLinux with Python 3.3.0 I needed to change "/usr/bin/env python"
> to "/usr/bin/env python2". Once I got past that, HEAD build ran fine
> and I don't hit the same issue.

Yeah, it might be time to change that line with some distributions
defaulting to 3... just hasn't been an issue yet.

>> Having said that, I wouldn't mind actually knowing what's going on
>> here. If there's any way you could provide more information (i.e., the
>> status at the time, any additional file changes), or a test case, then
>> that would be immensely helpful. There's no way that should happen
>> based on the output here.
>> cheers,
>> Kai
> For reproducing the problem, I can do it on every git repo that I've
> tried. I set up a test git repository where I made 2 commits, 3
> changes: add blank README, commit, add line of text to README, commit,
> add 2nd line to README.
> At this point if I run Meld 1.6.1 (installed version) on the
> repository, it opens up the directory diff fine, but if I try double
> clicking on the README file it indicates as modified, it gives the
> error from my earlier email.
> If I run Meld 1.7.0 (HEAD version, gb71056c) on the repository, it
> opens both the directory and file diff without issue.

So I followed your instructions, but can't reproduce the problem at
all. Any chance that you could open a bug and attach a tar of your
example repo? Any other details would also be useful, such as Git
version and the like. While I'm glad that it's sorted in 1.7.0, that's
because we use a different method entirely, and it would be nice to
make sure that the 1.6 series continues to work for people.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]