Re: Meld failed on git repo

On Mon, Jan 7, 2013 at 11:26 AM, Kai Willadsen <kai willadsen gmail com> wrote:
> On 7 January 2013 09:37, Peter Olson <peter olson gmail com> wrote:
>> Let me know if you need me to run further tests or need more
>> information. I hit the bug my launch meld, opening the git directory
>> with the "Version Control Browser" tab, then double clicking on the
>> README file that was shown as modified.
>> """
>> Invoking 'patch' failed.
>> Maybe you don't have 'GNU patch' installed,
>> or you use an untested version of Git.
>> """
>> $ patch --version
>> GNU patch 2.7.1
>> """
>> - meld version: '1.6.1'
>> - source control software type: 'Git'
>> - source control software version: '1.8.1'
>> - the output of 'git diff --relative HEAD somefile.txt'
>> """
>> $ git diff --relative HEAD README
>> diff --git a/README b/README
>> index b9cab08..ba59d16 100644
>> --- a/README
>> +++ b/README
>> @@ -1 +1,3 @@
>>  This project aims to create a block duplication feature that supports
>> permissions and additional configuration.
>> +
>> +test added line
>> """
>> - patch command: 'patch -p1 -R -d /tmp/tmpc7xIo0-meld'
>> """
> Yeah that's weird. That version of Git is certainly untested, but I'm
> not aware of any breaking changes. If you'd like to try the current
> HEAD version of Meld, I'm pretty sure it will work for you. If not,
> I'd definitely like to hear about it.

Running HEAD version took be a bit before I realized that as I'm in
ArchLinux with Python 3.3.0 I needed to change "/usr/bin/env python"
to "/usr/bin/env python2". Once I got past that, HEAD build ran fine
and I don't hit the same issue.

> Having said that, I wouldn't mind actually knowing what's going on
> here. If there's any way you could provide more information (i.e., the
> status at the time, any additional file changes), or a test case, then
> that would be immensely helpful. There's no way that should happen
> based on the output here.
> cheers,
> Kai

For reproducing the problem, I can do it on every git repo that I've
tried. I set up a test git repository where I made 2 commits, 3
changes: add blank README, commit, add line of text to README, commit,
add 2nd line to README.

At this point if I run Meld 1.6.1 (installed version) on the
repository, it opens up the directory diff fine, but if I try double
clicking on the README file it indicates as modified, it gives the
error from my earlier email.

If I run Meld 1.7.0 (HEAD version, gb71056c) on the repository, it
opens both the directory and file diff without issue.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]