Re: Meld not working on Mac

On Fri, 9 Sep 2011 15:12:36 -0700 (PDT), Anas Mughal  wrote:

Honestly, Meld is the best merge tool that I have used so far.
Specially because it allows picking/merging modifications on a git
project. Hopefully, Meld will be ported over to Mac in the near
future.  Meld is a great product. I think the team should charge money
for commercial licenses.

For now, I installed Fink on my Mac OS and tried to run Meld under
it. After all the trouble of setting up fink and resolving its
quirks, I could not figure out why Meld was not seeing files in its
open file dialog box. I will give another try today and try to change
file permissions, etc.


From: Kai <kai willadsen gmail com>
To: Anas Mughal <anasmughal yahoo com>
Cc: "meld-list gnome org" <meld-list gnome org>
Sent: Friday, September 9, 2011 2:21 PM
Subject: Re: Meld not working on Mac

On 10 September 2011 04:46, Anas Mughal <anasmughal yahoo com> wrote:
> Meld is a great compare and merge tool.
> I tried to set it up on my Mac using Fink. I am now able to run it but I
> don't see any files when I use the open file dialog.
> Is there a setting or some permission issue that I need to fix.

There shouldn't be, no.

I've used Meld on OSX via both macports and using a jhbuild-ed
environment, and both work reasonably well (with some cosmetic
issues). I'm not aware of anything that should cause file-dialog
issues on a mac, or at least none that are specific to Meld. Sorry to
not be more help, but supporting different build environments is not
really feasible.

Meld works for me on 10.6 under fink (configured as 32bit, I haven't
tried other setups but I know others use it too). I'm the
package-maintainer there. I usually run it from an xterm:

$ meld file1 file2

window opens with file1 in left pane and file2 in right pane.


Daniel Macks
dmacks netspace org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]