Re: Compiling mc 4.8.15


My understanding for all the routines that mc needs, e.g gettext, pkg-config, etc, i am have those installed 
into /usr/lib  either bin or local under there.

I deleted pkgconfig, and tried to reinstall that, and got error again when i tried ./configure 
--with-internal-glib and got a "undefined achitecture for x86_64:" error.

I'm a technical writer with a CS background. If someone could tell me the steps to compile all this for 
working under OS X, i would gladly write this up in a clear manner and donate to the mc doc effort!

Thanks for any help!


On Sun, Feb 07, 2016 at 03:08:45AM +0100, Andrey Gursky wrote:
On Sat, 06 Feb 2016 18:18:05 -0600
Russell Urquhart <russurquhart1 verizon net> wrote:


I'm suspecting pkg-config was not installed/properly.

I ran the command below, in the directory specified and got a pkg-config command not found.

Should i just delete that whole directory and try reinstallinbg pkg-config?

I haven't specified a directory to run pkg-config in. I just suggested
to define PKG_CONFIG_PATH not via an additional export command but
simultaneously with calling some program, which depends on it.

When you're installing gettext, pkg-config,.. do you know where they
are installed to? If they aren't installed into some system
directories, then one should take into account, that for each program
there are 2 important directories: "bin" and "lib". The "bin" should be
included into the PATH environmental variable and "lib" into
DYLD_FALLBACK_LIBRARY_PATH (I believe, since I'm not on Mac).

Also it's important to know, whether you're building/installing all
this stuff under a user/admin account.

But since you've already encountered problems, may be it'd be better to
follow some HOWTO, if there is one, or just wait until mc get packaged?
If you still want to do it by yourself, be prepared to search through
the net for some solutions for general issues, which are not mc related.

Maybe there is someone on Mac here on the list, who could assist better?

On Sat, Feb 06, 2016 at 09:24:27PM +0100, Andrey Gursky wrote:
On Sat, 06 Feb 2016 13:13:35 -0600
Russell Urquhart <russurquhart1 verizon net> wrote:


I did that but still got an glib-2.0 couldn't be found or glib is too old error.

Any other ideas?

Thanks for all the help!


in order to see whether there is a defect in mc's configure or
something is still wrong with PKG_CONFIG_PATH, try run following in a

PKG_CONFIG_PATH=<PATH TO YOUR GLIB INSTALL PREFIX>/lib/pkgconfig pkg-config glib-2.0 --modversion

You should see:

If not, PKG_CONFIG_PATH is still not properly setup. You can search for
glib-2.0.pc, like:

find / -name glib-2.0.pc

and then adjust PKG_CONFIG_PATH to point to the directory, containing


On Sat, Feb 06, 2016 at 04:25:06PM +0100, Yury V. Zaytsev wrote:
On Sat, 2016-02-06 at 08:08 -0600, Russell Urquhart wrote:


when you run ./configure? 

No, that's

    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

before you run ./configure:

Sincerely yours,
Yury V. Zaytsev

mc mailing list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]