Re: Keymapping problems again.

 gmail or any web-mail is crap ! US-infinite-frontier/no-economy view !
I have to pay extra dial-up fees to check If I've already posted a mail.

kilgota banach wrote:
I had this problem some time ago and finally did some I-forget-what
kind of magic to deal with it. This time it is really weird, because the
problem does not affect all users. What was the "cause" of the problem is
that I ran out of disk space, upgraded to a much larger hard drive, and
while I was at it I upgraded the operating system from Slackware-12.0 to
Slackware-current, which appears to me to be in the last stages before
the next release. I did the upgrade in part because there were a rather
huge number of security patches to apply, in any event.

Here is the problem:

1. Start up X (fvwm2, no fancy desktop) as a user.


2. Open an xterm and start MC. No problems. Everything nice.

3. In an xterm, do "su" and give the password to do a root session in that

Then, in the root window only, the Alt key followed by a keystroke (Alt-s
for search the directory, for example) will print a funny character at the
command line and otherwise will not do what it is supposed to do. As I
said, this does not happen if one is a user. Moreover, the Cntrl key has
taken over the abilities of the Alt key in addition to its own. For
example, Cntrl-s will permit the downward search of the directory, and
Cntrl-Enter will bring something down to the command line now, instead of
Alt-Enter, which does not work. Again, all of these things continue to
work as they should if one is a user, in the same X session.

! Wow, this is BAD!
I've run mc on mulinux, slak3, rh6.2, madrk9.1, FC1 and never had
such problems. You should 'step back to known territory'.
So it works OK in VT mode ?

Recently I tried to install slak-12 because I'd fetched the *tgz
for wine, and old slak-3 was OK.  I've shelved slak-12, after
weird symptoms, which you won't believe: after booting
'somewhat', I can't boot my other partitions/installations
without first going to boot Win98 and then RH6.2.

It's a BAD idea to be using the bleeding edge version !
BTW I've tried non-root login, just to say I've been there,
but the continual maintenance needed makes it intolerable
to use, for me.

== Chris Glur.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]