Re: Keymapping problems again.


The more I look into this problem it seems that this is not anything related per se to MC or its configuration, but rather the problem is most likely to involve X permissions. Thus, I should properly not be bothering this list about it but should instead go and chase someone else. Other than that, hello and thanks for answering. I seem to have dialed a wrong number, but how are you anyway? Below is a more complete description of the problem, and also a bit of off-topic stuff, in part in response to points you brought up. Read on.

On Thu, 24 Apr 2008, chris glur wrote:

gmail or any web-mail is crap ! US-infinite-frontier/no-economy view !
I have to pay extra dial-up fees to check If I've already posted a mail.

(Is this meant for me? I am using pine, and is my own Linux mail server machine, so I am not using either of what you name. BTW I totally agree that any web-mail system totally sucks.)

kilgota banach wrote:
I had this problem some time ago and finally did some I-forget-what
kind of magic to deal with it. This time it is really weird, because the
problem does not affect all users. What was the "cause" of the problem is
that I ran out of disk space, upgraded to a much larger hard drive, and
while I was at it I upgraded the operating system from Slackware-12.0 to
Slackware-current, which appears to me to be in the last stages before
the next release. I did the upgrade in part because there were a rather
huge number of security patches to apply, in any event.

Here is the problem:

1. Start up X (fvwm2, no fancy desktop) as a user.


2. Open an xterm and start MC. No problems. Everything nice.

3. In an xterm, do "su" and give the password to do a root session in that

Then, in the root window only, the Alt key followed by a keystroke (Alt-s
for search the directory, for example) will print a funny character at the
command line and otherwise will not do what it is supposed to do. As I
said, this does not happen if one is a user. Moreover, the Cntrl key has
taken over the abilities of the Alt key in addition to its own. For
example, Cntrl-s will permit the downward search of the directory, and
Cntrl-Enter will bring something down to the command line now, instead of
Alt-Enter, which does not work. Again, all of these things continue to
work as they should if one is a user, in the same X session.

! Wow, this is BAD!

Irritating, yes.

I've run mc on mulinux, slak3, rh6.2, madrk9.1, FC1 and never had
such problems. You should 'step back to known territory'.

Slackware is what I know, since 1996.

So it works OK in VT mode ?

Yes, here is an itemized list of works/doesn't work

1. Log in as root, in VT.  Works
2. Log in as root, start an X session. Works
3. Log in as user, stay in VT. Works
4. Log in as user in VT, then as root using su command. Works
5. Log in as user, then start X, open an xterm          Works
6. Log in as user, start X, open xterm, do su in xterm. Does not work.

Note that "works" means the Alt key works normally, and "does not work" means the Alt key does not work normally, but instead it continues to give the keycode mappings for other than standard characters even though one started up MC. The specific result for Alt-S is a lowercase o with an accent aigu on top (which would make it a long vowel in Hungarian, etc., etc.). I think that you ought to be able to duplicate this character by opening an xterm and _not_ starting MC or anything else, but just typing Alt-s at the command line. At least, that works over here. But apparently my mail configuration does not let me transmit such a keystroke combination through pine.

At any rate, it does seem from all of the above case-by-case analysis that I am suffering from some kind of permissions problem. It does seem clear that it is very unlikely that this is a problem with MC. It appears more likely that it is a problem with permissions related to switching the user once one has started X.

Recently I tried to install slak-12 because I'd fetched the *tgz
for wine, and old slak-3 was OK.  I've shelved slak-12, after
weird symptoms, which you won't believe: after booting
'somewhat', I can't boot my other partitions/installations
without first going to boot Win98 and then RH6.2.

WTF? I have never seen such a thing. But, thinking about it, if it is not a bootloader problem, then the most likely explanation I could think of is, that Slackware-12 and RH6.2 were using different versions of libc. To try to run things which were compiled with a later version of libc when only the earlier version is present can cause especially nasty problems. Namely, said programs usually will refuse to run. I do not know which of the two distros had the later libc version, but on reading this I would bet they were not the same. If that is the case and you were trying to share your /lib directory with both of the releases then, yes, that could lead to trouble.

It's a BAD idea to be using the bleeding edge version !

Why? If we all believed that then where would we be? Also this can cut both ways. Sometimes the new "bleeding edge" support contains fixes for known bugs in old code, or provides much better functionality. For example, I am the author and maintainer of libgphoto2/camlibs/digigr8, which supports consumer digital cameras with several chipsets in them that came from S&Q Technologies. These cameras were fully supported in libgphoto2-2.4.0 which was released in the first half of 2007, and I posted some major improvements to the image-processing code within the last week.

Recently I had to deal with a user who wrote to gphoto-devel about wanting his camera to work better. The only problem was that his distro's release of libgphoto2 was two years old. That was no accident, either. The distro prides itself on using old stuff, following the fallacy that older is always better. It does not seem to occur to them that sometimes old code is replaced in order to make things work better. That distro would be much better off as far as digital camera support is concerned if it went for the bleeding-edge stuff every time instead of doing the opposite. Frankly, I think their attitude about this is really stupid and causes extra work by having desperate users communicate with developers who already solved the "problem" a long time ago. I did not mention the name of the distro because I am not here to start a flamewar about distros.

BTW I've tried non-root login, just to say I've been there,
but the continual maintenance needed makes it intolerable
to use, for me.


Thanks for being concerned about the problem.

Theodore Kilgore

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]