Re: Display Corrupted over remote connections for RHEL5 and CentOS5

Pavel Tsekov wrote:

-------- Original-Nachricht --------
Datum: Wed, 11 Jul 2007 17:08:02 -0500
Von: dead
An: mc gnome org
Betreff: Display Corrupted over remote connections for RHEL5 and CentOS5

When running mc from console attached to an RHEL5 or CentOS5 system, it
displays fine, but when running mc over a remote/ssh connection, the
display is badly corrupted and becomes even more corrupted if you try to
navigate. I've already tried changing my $TERM environment variable to
various other settings - linux, xterm, vt100, etc, - but to no avail.
They all seem to have the same display issues. Any light you could shed
on the situation would be most appreciated. Google has not been kind! =)

I usually connect via openssh over the most current iTerm on OSX
10.4.10. However, I've tested with other terminal programs - putty on
winxp, securecrt on winxp, regular terminal in osx, etc - and they all
are plagued with the same corruption of the display.

When you ssh to the remote machine type the following command:

export LANG=C

or configure your terminal emulator to interpret UTF-8 input.


Thanks Pavel.

I chose the second option and it worked wonderfully. For others using
iTerm on OSX, create a terminal profile that uses utf-8 encoding instead
of the default. Then create a bookmark for the EL5 system you want to
connect to using 'ssh $$USERNAME$$ server host name' as the command and
tell it to use the new terminal profile you created. this is how I did
it and it's working perfectly for me.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]