Re: Antwort: Re: Antwort: Re: mcedit and file locking

> On Mon, 25 Sep 2006, karl kappel segmueller de wrote:

>>>> Where is the dead symlink located?
>>> In the same directory as the file being edited.
>>>> If one user opens a file with mcedit for editing and another user
>>>> does the same with mcedit should he get a message about this fact?
>>> Yes.
>>>> The mc version is 4.5.51 wiht RedHat 7.2
>>> That version doesn't support locking. Locking support was
>>> added starting with MC 4.6.0.
>> I've updated MC to 4.6.0 on the RedHat 7.2 system, but there is still no
>> dead symlink and
>> no message editing a file already opened by somebody else.
>> I've tried the same with MC 4.6.1 on a gentoo system, but also no symlink
>> and no message.
>> Is there a special option to activate locking support, or is there
>> something else to do?

> Well, maybe you are experiencing the problem described here:


No - it seems not to be the problem - I didn't start the editor from commandline.
So I think there must be a kind of bug in the packages I've used (both RedHat and Gentoo).

> If this is the case you have to download the patch and apply it
> to your local source and rebuild. Or you can get the latest snapshot
> of MC and build it:


Now I have compiled mc-4.6.1 myself and it works fine with locking support.

One suggestion for the message sent in case of a locking situation:
Default answer is "Grab lock" - I think to have "Ignore lock" as default would be the better choice.
But this is my personal opinion and I can change the code myself.

> The link name looks like this ".#filename", so if you have turned off the
> listing of hidden you may not see it as well.

Thank You for Your help.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]