Re: mc-4.6.1-20060912.patch

On Wed, 13 Sep 2006, Thomas Dickey wrote:

On Wed, 13 Sep 2006, Pavel Tsekov wrote:

That tarball should be based on the CVS state from yesterday - so
it is pretty much the same as the CVS version. I am building
MC with ncurses support for quite a while and I haven't seen
problems with the mouse support.

perhaps you're using gpm. I use it rarely since it generally interferes with X.

The MC homepage is located at and has been
there for quite some time. On the project homepage you can find important information about accessing the latest snapshot, CVS, as well as the project's bug tracking system.

I do build and test MC not only on linux but also on Solaris and Cygwin and not so often on some other systems too. None of them use gpm.

A quick check of the snapshot using my configuration shows the same bugs that I noticed in the release:

        a) cursor keys are not handled properly using the slang
           configuration when running in screen.  (But see below).

        b) there is no support for mouse using ncurses in xterm (or any
           other terminal supported by ncurses, of course).

Ok I cannot test right now since it is really late but I'll do tommorow. In the meantime, please, post the exact configuration that you're using so that I can try with your seettings.

I had noticed the mouse problem in 2002 when I sent a patch to Pavel Roskin, but had not found time then to fix it. The problem is still the same. Perhaps it would not be hard to resync my 4.6.1 patch against your snapshot, but since the packagers I normally deal with are using 4.6.1, that was where I started.

You are asuming that everyone is aware of the problem you speak of.

Would you, please, exlpain the problem that you're seeing and the
reasons behind your patch. Does it have something to do with ?

not exactly. Since I maintain ncurses, I deflect bug reports that are incorrectly citing ncurses. I happened to think about MC this week since I noticed some comments via google on one of the newsgroups that indicated someone's cursor keys did not work in MC. That might be the same issue
that I noted above.

Do you mind to post a reference to that discussion so it can be verified ?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]