Re: problem with viewing large files

Hi, Adam!

I did use the large file option when I compiled mc, i could see the 4gb
file with no problems.

Your original message didn't mention 4gb files.  It mentioned a file
slightly below 4gb that mc could not view and a file slightly above 4gb
that mc could view (but we don't know if mc just shows the file's size
minus 4gb).

I suspects its a problem with the contents of the file (its a dgdump file
that was ment to be cpio).

It should be easy to determine.  Shift-F3 calls the viewer without 
checking the contents of the file.  On the other hand, you could try to 
open another file 3.7gb long.  You can use a sparse file to avoid filling 
your hard drive with zeroes:

dd if=/dev/null of=bigfile bs=1M seek=3700

Actually, I tried to view the resulting file with the CVS version of MC
and got the same error, so your assumption about the file contents is
probably wrong, but you can check anyway - finding another bug won't hurt.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]