Re: Spurious warning message when entering symlink directory (fwd)


On Wed, 24 Aug 2005, Pavel Tsekov wrote:

> ---------- Forwarded message ----------
> Date: Tue, 23 Aug 2005 18:15:14 +0200
> From: Christopher Gautier
> To: Pavel Tsekov
> Subject: Re: Spurious warning message when entering symlink directory
> > I couldn't reproduce it neither on Fedora Core 3 running latest cvs MC
> > neither on Cygwin where I tried MC 4.6.1. I tried to enter 'bar' by
> > hitting enter when the cursor was over it and by issuing 'cd bar' in the
> > command prompt widget.
> I'm surprised. I've seen this bug countless times for 3 years on RedHat
> (3 years ago) and Debian (these days). I tried the 4.6.1 version
> (that is, the non-debianized, non-redhatized), and it was still there.
> I admit I didn't try the CVS.
> My patch consists in resolving symlinks before doing a strcmp, so
> there may be a real problem, or I am missing some key factor that
> would be trigger the bug.
> Maybe the terminal (aterm), the shell (zsh), the environment,
> or the locale intervene...

I haven't investigated the patch - I just tried to reproduce the problem
using the steps that you provided. I did not see what you see.

> I guess I'll have to patch my own mc and live with it...

Don't get me wrong - I didn't say that your patch is not good. It may well
make perfect sense.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]