Re: Include glib into mc distribution?

> I saw some posts in the net from users who were having problems because of
> the glib. Most of these users are not users anymore just because they were
> unable to build mc :-(
> I found the following example in the cygwin list:
> ////////////////////////////////////////////////////////
> I am trying to compile mc 4.5.55 with no luck.  First, it complained I did
> not have glib so I tried to install that.  However, glib complained I did
> not have pkgconfig.  I downloaded the latest version of pkgconfig and I
> can't get that to install either.  I read the instructions and typed
> "./configure" then "make" then "make install".  I get a variety of errors
> and eventually, it does not work.

The documentation for mc 4.5.55 specifies clearly that it requires glib
1.2.x.  That guy apparently took glib 1.3.x.  In fact, the main reason why
I don't want to switch to glib 1.3.x is because it requires pkgconfig and
pkgconfig needs to be compiled by the end user.

This message should be forwarded to glib developers - it's their problem.  
I have no time to rewrite pkgconfig in shell, but somebody should do it!

I actually put 1.2.x everywhere where glib was mentioned in INSTALL and 
INSTALL.FAST.  But I missed README.  I'm fixing it in CVS now.

> Apparently this guy is not mc user anymore...
> And he was having problem on machine with "root" access, forget about
> production machine with tyrant sysadmin.

Sysadmins are supposed to install precompiled software from trusted
sources or read the documentation before compiling.

> I also had a problem with glib - its installer put glib.m4 to a wrong place,
> it took me some time to figure out this problem.

That's very interesting!  You are mixing together things that are just
inconvenient and things that are very wrong!

When compliling an package that uses automake and the tarball was properly
checked by "make distcheck" (I did it with 4.5.55), no files that are part 
of the distribution should be regenerated.

Could you please provide more details about the failure?  Can you still
reproduce it?

> The size of glib is about 500K, which will be about 200K compressed, so the
> size it is not a problem since the mc distribution is about 3 Megs.
> We already have slang and gettext included and this is very good - people
> don't have hassles with them.
> Let's be consistent!

glib-1.2.10.tar.gz is 412k compressed.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]