Re: [libxml++] Node's xpath methods
- From: Stefan Seefeld <seefeld sympatico ca>
- To: libxmlplusplus-general lists sourceforge net
- Subject: Re: [libxml++] Node's xpath methods
- Date: Mon, 17 Feb 2003 09:13:14 -0500
Murray Cumming wrote:
Node now has
std::string get_path() const;
Should we rename this to get_xpath()?
what else can 'path' mean in the context of xml ? libxml2 calls
the appropriate method 'xmlGetNodePath'...
Also, maybe we should rename
NodeSet find(const std::string& xpath) const;
to find_by_xpath() or something similar? find() seems a bit generic,
particularly when it just takes std::string which is also very generic.
that's true (and I agree that it should take an 'XPath' object instead
of a string). However, I do think that the xpath based find is the most
generic find that you can do in the context of xml. Whatever you want to
look for, there is a way to express that with xpath.
Regards,
Stefan
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]